So funktioniert JustAnswer:
  • Fragen Sie einen Experten
    Tausende Experten in über 200 Kategorien.
  • Erhalten Sie eine professionelle Antwort
    Per E-Mail oder sofortiger Benachrichtigung, während Sie auf unserer Website warten. Stellen Sie ggf. weitere Anschlussfragen.
  • 100%ige Zufriedenheit garantiert
    Bewerten Sie die erhaltene Antwort.
Stellen Sie Ihre Frage an Tronic.
Tronic
Tronic, IT-Specialist
Kategorie: Computer
Zufriedene Kunden: 13975
Erfahrung:  Elektroniker und EDV-Service
31581453
Geben Sie Ihre Frage in der Kategorie Computer hier ein
Tronic ist jetzt online.

Guten Tag. Ich habe eine Frage zu der Überprüfung von zwei

Kundenfrage

Guten Tag.
Ich habe eine Frage zu der Überprüfung von zwei verschiedenen Werten.

In der Spalte A sind verschiedene Werte. In der Spalte B sind Werte von +1 bis -1. In der Spalte C soll nun der Wert von Spalte A abgebildet werden, wenn auf der selben Linie der Wert aus Spalte B über 0 liegt. Die Spalte C bleibt dann so lange leer bis der Wert aus Spalte B wieder unter 0 fällt. In diesem Fall wird jener Wert von Spalte A auf der gleichen Linie erneut abgebildet. In der Spalte C werden somit nur Werte aus Spalte A abgebildet sobald sich der Wert aus Spalte von positiv in negativ ändert und umgekehrt.

z.b.
1) A: 1000 / B: 0.4 / C: 1000
2) A: 1050 / B: 0.5 / C: 0
3) A: 1090 / B: 0.55 / C: 0
4) A: 1010 / B: -0.95 / C: 1010
5) A: 990 / B: -0.80 / C: 0

Können Sie mir bei dieser Überprüfung behilflich sein?

Besten Dank für Ihre Bemühungen.
Gepostet: vor 5 Jahren.
Kategorie: Computer
Experte:  Tronic hat geantwortet vor 5 Jahren.
Hallo lieber Kunde,

vielen Dank, dass Sie sich an Justanswer gewandt haben. Gerne versuche ich Ihnen bei Ihrem Problem behilflich zu sein.

Ohne es jetzt getestet zu haben, schreiben Sie mal in die Zelle C2 die folgende Formel:

=WENN(VORZEICHEN(B2)=VORZEICHEN(B1);0;B2)

Dann ziehen Sie die Formel mit der linken Maustaste an dem Anfasser der Zelle (rechts unten) nach unten um sie fortzuführen.

Dann müßte das doch Ihr gewünschtes Ergebnis liefern? Die Zelle C1 können Sie ja noch manuell ausfüllen.

Für Ihre Rückmeldung steht Ihnen der Button "Dem Experten antworten" zur Verfügung.
Experte:  Tronic hat geantwortet vor 5 Jahren.
Verehrter Kunde,

Ihre Frage ist noch geöffnet. Ich hoffe ich konnte Ihnen mit meinen Informationen weiterhelfen.

Wenn Sie noch Rückfragen an mich haben sollten, verwenden Sie bitte den Button "Dem Experten antworten" unterhalb meiner Antwort.

Wenn Sie keine weiteren Rückfragen mehr an mich haben, schließen Sie die Frage bitte ab in dem Sie auf "Akzeptieren" klicken. Vielen Dank.