So funktioniert JustAnswer:
  • Fragen Sie einen Experten
    Tausende Experten in über 200 Kategorien.
  • Erhalten Sie eine professionelle Antwort
    Per E-Mail oder sofortiger Benachrichtigung, während Sie auf unserer Website warten.
    Stellen Sie ggf. weitere Anschlussfragen.
  • 100%ige Zufriedenheit garantiert
    Bewerten Sie die erhaltene Antwort.
Stellen Sie Ihre Frage an Pucky80.
Pucky80
Pucky80, IT-Systemkaufmann
Kategorie: Computer
Zufriedene Kunden: 1575
Erfahrung:  MCITP (Microsoft Server 2008 Enterprise Administrator)
59969578
Geben Sie Ihre Frage in der Kategorie Computer hier ein
Pucky80 ist jetzt online.

Hallo, ich schlage mich seit mehreren Tagen mit folgendem Problem

Kundenfrage

Hallo, ich schlage mich seit mehreren Tagen mit folgendem Problem herum. Für die Spezifizierung des Leitwertes im Wasser müssen entsprechend der Temperatur Umrechnungsfaktoren eingegeben werden. Das heiß: in A1 wird manuell die Temperatur eingegeben in B1 wird der gemessene Leitwert eingegeben. Nun das Problem: Bei einer Temp von 28ºC muss der gemessene Leitwert mit dem Faktor 0,94 multipliziert werden, analog dazu bei 29ºC wäre mit dem Faktor 0,922 zu multiplizieren usw. usf. Die Faktoren sind nicht linear! Ich möchte erreichen in einer neuen Zelle das jeweilige Ergebnis bei wechselnden Temperaturen analog zu den einzelnen der jeweiligen Temperatur zuzuordnenden Umrechnungsfaktoren angezeigt zu bekommen, d.h. in der zu erstellenden Formel muss es möglich sein die Umrechnungsfaktoren entsprechend zugeordnet zu der jeweiligen Temperatur einzugenben. Vielleicht können Sie mir behilflich sein. Vielen Dank XXXXX XXXXX Mühe
Andreas

temp lw lw bereinigt

28 354 332,76
=+WENN(A5=28;B5*0,94)

=+WENN(A5=28;B5*0,94)=+WENN(A5=29;B5*0,922)
Gepostet: vor 5 Jahren.
Kategorie: Computer
Experte:  Pucky80 hat geantwortet vor 5 Jahren.
Ok, ich hoffe ich habe Sie richtig verstanden.

Sie werden den Umweg über eine Zusatztabelle gehen müssen. Eine Wenn Bedingung ansich kann sehr schnell sehr groß werden wenn zuviele Faktoren berücksichtig werden müssen.

mein Beispiel sieht folgendermaßen aus:

A1 Temperatur B1 Leitwert C1 Ergebnis
28 354 332,76

So soll es endgültig aussehen, nur dass eben das Ergebnis berechnet werden soll.

machen Sie im Tabellenblatt eine Spalte für Temp und daneben eine für den Faktor, also z.b.

F1 Temperatur G1 Faktor
1 0,1
2
3
.
.
.
28 0,94
29 0,922

Wenn Sie dies so haben muss die Formel folgendermaßen lautet (also in zelle C2 wo das Ergebnis berechnet werden soll):

=A2*SVERWEIS(A2;F2:Gxx;2)

Das xx steht für die letzte Reihenzahl. Ich habe Ihnen ein Beispiel m it angehangen und hoffe ich habe mich korrekt ausgedrückt.

Excel Datei

Bei Rückfragen stehe ich ab morgen wieder zur Verfügung.
Experte:  Pucky80 hat geantwortet vor 5 Jahren.
War mein Tip hilfreich? Bitte um Rückmeldung oder Akzeptierung der Antwort. Vielen Dank :)

Ähnliche Fragen in der Kategorie Computer