So funktioniert JustAnswer:
  • Fragen Sie einen Experten
    Tausende Experten in über 200 Kategorien.
  • Erhalten Sie eine professionelle Antwort
    Per E-Mail oder sofortiger Benachrichtigung, während Sie auf unserer Website warten.
    Stellen Sie ggf. weitere Anschlussfragen.
  • 100%ige Zufriedenheit garantiert
    Bewerten Sie die erhaltene Antwort.
Stellen Sie Ihre Frage an IT-Fachinformat...
IT-Fachinformatiker
IT-Fachinformatiker, Systemadministrator
Kategorie: Computer
Zufriedene Kunden: 6971
Erfahrung:  Software Entwicklung, Projekt Erfahrung, Windows-Netzwerke, Linux-Netzwerke, Windows/Linux-Server
32504664
Geben Sie Ihre Frage in der Kategorie Computer hier ein
IT-Fachinformatiker ist jetzt online.

Guten Morgen zusammen, ich habe ein Problem mit unserem

Kundenfrage

Guten Morgen zusammen,

ich habe ein Problem mit unserem XRaid.
Das Raid war links mit 4 Festplatten als RAID 5 in Betrieb.
Jetzt haben wir die linke hälfte auf 7 Festplatten aufgestockt.
Ebenfalls kamen im rechten Teil gleich 7 Stück dazu.

Jetzt das Problem:

Raid Admin zeigt mir die (nach RAID Level 5) zur Verfügung stehende Kapazität des jeweiligen Arrays korrekt an. Im Festplattendienstprogramm stehen im linken "alten" Array aber immer noch nur die alte Gesamtkapazität und das neu erstellte Array existiert gar nicht.

OS X ist auf dem neuesten Stand (10.6.3) auch Raid Admin ist meines Wissens die Aktuellste Version (1.5.2b3)

Haben Sie irgend eine Idee was das sein könnten?

Vielen Dank XXXXX XXXXX im Voraus.


Stefan Denzel
Gepostet: vor 7 Jahren.
Kategorie: Computer
Experte:  IT-Fachinformatiker hat geantwortet vor 7 Jahren.
Hallo, also wenn Sie richtig verstanden haben, dann haben Sie insgesamt 14 Platten im Einsatz zu je einem Array von 7 Platten aufgeteilt Ihnen werden beide Arrays korrekt angezeigt jedoch nur die "alte" Gesamtkapazität der ersten 7 Platten und rtotz der Tatsache, das Sie dieses zweite Array mehrfach erstellt haben sehen Sie nur die "alte" Gesamtkapazität und das zweite Array überhaupt nicht ist dies so korrekt?
Gruss Günter
Kunde: hat geantwortet vor 7 Jahren.
Hallo Günter,

ja das ist korrekt. Das RaidAdmin Programm gibt alles als bereit wieder, aber ich habe keine verwendbare Festplatte über Festplattendienstprogramm oder sonst wie sichtbar.

Gruss Stefan
Experte:  IT-Fachinformatiker hat geantwortet vor 7 Jahren.
Hallo Stefan, also das hört sich für mich so an, als wäre dort eine Spiegelung eingerichtet d.h. in diesem Fall würden die ersten 7 Platten auf die letzten 7 Platten gespiegelt in diesem Fall würdest Du natürlich nur die Kapazität der ersten 7 Platten sehen, weil ja die letzten 7 Platten für das Mirroring benutzt werden. Offenbar ist ja alles "grün" d.h. kein Plattendefekt, Arrays erzeugen klappt auch wunderbar usw. das könnte ich mir z.B. vorstellen. Eine andere Ursache wäre, das die letzten 7 Platten nicht initalisiert wurden d.h. in diesem Fall würden die Platten gar nicht erst gesehen werden. Oftmals muss nach der ERstellung eines Arrays das selbige auch initalisiert werden, damit es voll zur Verfügung steht. Dummerweise sitze ich jetzt nicht davor. Wenn es Protokolle gibt, wäre es hilfreich zu erfahren ob dort Fehlermeldungen auftauchen. Gruss Günter
Kunde: hat geantwortet vor 7 Jahren.
Hallo Günter,

die 7 Festplatten sind je ein getrenntes Array, jedes mit eigenem Kontroller, Fibre Channel usw.
Initialisiert hab ich das neue Array schon mehrmals, das alte wie gesagt nur durch "hinzufügen"
aber soweit ich das bei Raid Admin verstanden habe werden diese Platten auch bei der Einbindung initialisiert. (Hat auf jeden fall fast schon Tagelang gedauert).

Gespiegelt ist dabei nichts.
Protokolle sieht es glaube ich schlecht aus.

Gruß

Steff
Experte:  IT-Fachinformatiker hat geantwortet vor 7 Jahren.
Hallo Stefan, dann würde es ja bedeuten, das Du zwei separate Arrays hast, die jeweils als eine gesamte HD fungieren sozusagen ein zusammengefasstes Volume und sich die Arrays primär um die Performancesteigerung kümmern. Wenn das erstellen der Arrays korekt geklappt hat und alle anderen Dinge wie Controller. Leitungen usw. "grün" zeigen also funktionsfähig sind dann bleiben nur noch wenige Lösungen. Klassischerweise würde man wahrscheinlich in diesem Fall vermuten, das der zweite Plattenverbund der ja als eine HD (das wäre der einfachste Fall) erscheinen müssten dies müsste bei Windows, Unix, Linux wie auch Mac OS X der Fall sein. Das bedeutet diese Datenträger müssen irgendwie auftauchen wie erscheint denn der erste Plattenverbund hast Du da genau ein Laufwerk oder hast Du mehr als ein Volume erstellt? Einige würden sagen formatieren, Speciherbereich festlegen usw. aber ich denke das wirst Du als erstes vermutet haben. Gruss Günter
Kunde: hat geantwortet vor 7 Jahren.
Hallo Günter,

ja so war es gedacht.

Das erste sowie das zweite Array soll für den Betreib jeweils als ein "Festplatte" fungieren.
Das erste "alte" Array ist im Finder auch als solches sichtbar und verwendbar.
Das neue soll eigentlich nur als zusätzliche Sicherung der Daten des ersten dienen.
Jedoch kann ich über das Festplattendienstpr. nur das eine alte Array bzw. die "Festplatte" erkennen,
das andere existiert nicht, sonst hätte ich es da mal Formatiert oder Partitioniert, aber es ist nix da.

Ist schon verzwickt.

Gruß

Stefan
Experte:  IT-Fachinformatiker hat geantwortet vor 7 Jahren.
Hallo Stefan, kennst Du Dich mit der Terminalkonsole des Macs aus? Macs haben ja eine Unixartige Umgebung diese ist zwar stark an Apple angepasst aber grundsätzlich sollte einiges gehen. Bei einem Unixsystem (auch unter Windows nutze ich einen Unixkern das geht z.B. auch) gibt es bestimmte Files (unter Unix gibt es nur Files sonst nix) und zwar geht es mir darum, ob Dein Array auch gemounten wurde versuch mal folgendes:

Öffne ein Konsolenfenster also ein Terminal und gucke bitte mal nach der Ausgabe der folgenden Befehle:

df -h

cat /etc/fstab

der erste Befehl zeigt alle Platten an der zweite zeigt alle Platten/Laufwerke an, die beim Systemstart autoamtisch gemountet werden ich bin mir aber nicht sicher, ob MacOS X das genau dort speichert aber ich hoffe es, sollte eigentlich da sein.

Ferner solltest Du mal in den Protokollen schauen und zwar ebenfalls auf der Konsole:

less /var/log/messages

Zeigt das primäre Systemprotokoll so an, das Du darin herum blättern kannst.

Wenn Dein Array nämlich weder bei df noch in der fstab aufgeführt wird dann ist es nicht korrekt gemountet bzw. überhaupt nicht gemountet. Das hatte ich auch schon mal bei anderen Kunden.

Gruss Günter




Kunde: hat geantwortet vor 7 Jahren.
Hallo Günter,

nur der erste Befehl brachte ein Ergebnis.
Dort ist das zweite Array nicht zu sehen und das erste mit der zu geringen Volumengröße.

Siehe unten:

Filesystem Size Used Avail Capacity Mounted on
/dev/disk3s2 149Gi 15Gi 133Gi 11% /
devfs 114Ki 114Ki 0Bi 100% /dev
/dev/disk2s2 149Gi 8.8Gi 140Gi 6% /Volumes/Server HD
/dev/disk1s2 76Gi 18Gi 58Gi 24% /Volumes/System
map -hosts 0Bi 0Bi 0Bi 100% /net
map auto_home 0Bi 0Bi 0Bi 100% /home
map -fstab 0Bi 0Bi 0Bi 100% /Network/Servers
/dev/disk0s3 931Gi 757Gi 174Gi 82% /Volumes/Backup Server Daten
/dev/disk4s3 1.4Ti 779Gi 618Gi 56% /Volumes/Server Daten

Das unterste ist das erste "alte" Array das eigentlich 2,73 Ti groß sein müsste, die anderen Volumes gehören zum XServe oder sind FireWire Platten.

Gruß

Stefan
Experte:  IT-Fachinformatiker hat geantwortet vor 7 Jahren.
Hallo, also:

Totalsize: Mounted on:
/dev/disk0s3 931Gi /Volumes/Backu
/dev/disk1s2 76Gi /Volumes/System
/dev/disk2s2 149Gi /Volumes/Server HD
dev/disk3s2 149Gi /
/dev/disk4s3 1.4Ti /Volumes/Server Daten

Das erklärt so einiges ;-) das zweite Array fehlt also soweit sind wir schon. Schaue bitte einmal in Raidamin nach, welchen Devicenamen das zweite Array tatsächlich hat dann könntest Du manuell folgenden Befehl im Terminal versuchen:

mount /dev/diskXYZ /Voulumes/DeinSpeicherplatz_DeinOrdner

/dev/diskXYZ <- Bedeutet das physikalische Gerät, das gemountet werden soll hier entsprechend das Gerät eintragen, welches von Raidadmin angezeigt wird

/Voulumes/DeinSpeicherplatz_DeinOrdner -> Der Ort an dem es gemountet werden soll kannst Du frei wählen, aber der Ort muss existieren und passende Berechtigungen aufweisen

Falls Raidamin kein Gerätenamen anzeigt muss ggf. einer erstellt werden wenn dies so ist, muss auch eine solche Funktion existieren.

Gruss Günter



Kunde: hat geantwortet vor 7 Jahren.
Hey Günter,

danke XXXXX XXXXX Antwort, leider muss ich jetzt dringend weg.

Gib mir doch bitte kurz bescheid wo ich diesen Devicenamen finde.
Spontan hätte ich nur eine MAC Adresse zu bieten.

Ich meld mich dann sobald ich wieder da bin.

Danke

Gruß

Stefan
Experte:  IT-Fachinformatiker hat geantwortet vor 7 Jahren.
Hallo, kein Thema der Devicename sollte bereits beim erzeugen des Arrays vorhanden gewesen sein und im Raidamin muss es einen entsprechenden Menüpunkt geben evtl. Diskinfo o.ä. jedenfalls muss er dort existieren. Ich bin ja hier :-) bis später Gruss Günter
Kunde: hat geantwortet vor 7 Jahren.
Hallo Günter,

bist Du nicht mehr online?

Habe irgendwie Probleme mit der Aktualisierung der Antworten.

Gruß

Stefan
Experte:  IT-Fachinformatiker hat geantwortet vor 7 Jahren.
Hallo, ich war zwischenzeitlich auch offline hier kann man sich aj ein- und ausloggen konntest Du schon was erreichen? Gruss Günter