So funktioniert JustAnswer:
  • Fragen Sie einen Experten
    Tausende Experten in über 200 Kategorien.
  • Erhalten Sie eine professionelle Antwort
    Per E-Mail oder sofortiger Benachrichtigung, während Sie auf unserer Website warten. Stellen Sie ggf. weitere Anschlussfragen.
  • 100%ige Zufriedenheit garantiert
    Bewerten Sie die erhaltene Antwort.
Stellen Sie Ihre Frage an Michael.
Michael
Michael, Informatiker
Kategorie: Computer
Zufriedene Kunden: 475
Erfahrung:  Server, Betriebssysteme, Netzwerke, Cisco, Hardware, PHP & MySQL, Java, ANSI C, C# Programmierung
28933948
Geben Sie Ihre Frage in der Kategorie Computer hier ein
Michael ist jetzt online.

M chte den Wert 1 in Zelle C ausgegeben haben wenn Zelle A 4

Kundenfrage

Möchte den Wert 1 in Zelle C ausgegeben haben wenn Zelle A=4 und Zelle B=060-1896-032 oder -031 oder(NNN) NNN-NNNN002 oder oder oder!
Gepostet: vor 7 Jahren.
Kategorie: Computer
Experte:  Michael hat geantwortet vor 7 Jahren.
Man müste dann die komplete zahl einige male beschneiden und dann eine WENN() Funktion Verwenden.

z.B. =WENN(UND(B1=4;LINKS(C1;3)="060");1;0)

Beste Grüsse
Kunde: hat geantwortet vor 7 Jahren.
Das Format der Werte(NNN) NNN-NNNN567 ist fest (Import Auswertung) !!! 060- und -567 ist zu vernachlässigen aber 1234 ist mein Kriterium. Funktioniert das auch mit MITTE(C1;4)(bei mir nicht)
Experte:  Michael hat geantwortet vor 7 Jahren.
Dies würde dann mit TEIL(C1;4;4) stattfinden
(mit den Zahlen müssen Sie halt etwas ausprobieren.)
Die erste sollte den Start signalisieren und die zweite die Länge.

Beste Grüsse

Verändert von Michael am 02.04.2010 um 00:28 Uhr EST
Experte:  hat geantwortet vor 7 Jahren.
Hab noch was ergänzt:

Die erste sollte den Start signalisieren und die zweite die Länge.
Michael und weitere Experten für Computer sind bereit, Ihnen zu helfen.
Kunde: hat geantwortet vor 7 Jahren.
=WENN(UND(B1=4;TEIL(C1;5;11)="189-565");1;" ")
OK, mit Teil ist OK und jetzt fehlt noch oder: "189-565" oder "191-543" oder oder oder.............
Experte:  Michael hat geantwortet vor 7 Jahren.
Hm oder oder oder was gäbe es denn alles noch für Varianten? je nach dem wie viele Werte da sind müsste man das evt nochmals auftrennen.

Und ist es ein Schreifehler von Ihnen dass es jetzt nur noch 2 mal drei Stelle sind?

Beste Grüsse